洛杉矶MC机房 高速低价18元起

尊云,给你尊贵体验!

宝塔面板安装不同PHP版本且可切换WordPress PHP版本升级

提示:如果官网是英文页面,建议使用谷歌浏览器能同步翻译页面。点击下载【谷歌浏览器最新绿色便携版】
注意:部分文章发布时间较长,可能存在未知因素,购买时建议在本站搜索商家名称,先充分了解商家动态。
交流:唯一投稿QQ80059284、唯一投稿邮箱:[email protected]、网友交流QQ群号640669696。

由于我们在建站时候不同的程序可能需要兼容的软件版本不同,比如有些是需要PHP5.3才可以运行,有些需要PHP7.0版本,在前面贝壳也有介绍到在四月底的时候,WordPress官方新版本发布之后会要求最低的PHP版本是5.6,以及后面可能会要求7.0以上(参考:WordPress 5.2版本将于四月底上线且最低需PHP 5.6.20版本)。

我们在服务器中部署的WEB环境,有些是开始安装的时候我们指定的PHP版本,虽然可以安装其他版本且设置默认新版本,但是并不是那么容易。比如贝壳也有在”OneinStack环境多PHP版本的安装共存与站点的设置“和”LNMP一键环境安装多PHP版本共存的方法“文章中介绍到目前较为常用的无面板脚本安装多个PHP版本的设置方法。

如果我们有在使用宝塔面板的话,这个就相对容易一些,我们可以直接在后台选择安装PHP版本,然后给不同的站点设置选择指定的PHP。如果我们后面有需要,可以参考这篇文章。

第一、有可能的备份数据

一般在宝塔面板后台直接安装不同的PHP版本是没有问题的,但是出于安全告知的考虑,贝壳还是建议如果确实不清楚的网友快照备份数据,或者自己熟悉的方式备份网站数据。

第二、宝塔面板安装多PHP版本

宝塔面板安装多PHP版本

宝塔面板后台,我们可以在软件管理菜单看到右侧有很多PHP版本,这里我是演示环境,看到我目前安装的是PHP7.0版本。这里如果我们需要多个PHP版本的话,直接在对应后面点击安装,且后面确认安装即可。

宝塔面板安装不同PHP版本且可切换WordPress PHP版本升级

这里我们可以看到在安装进度。需要等到安装完毕之后我们还可以下一步。

第三、网站更换PHP版本

网站更换PHP版本

我们可以看到上图,在对应需要更换PHP版本的网站设置中。可以选择上面安装的PHP版本。这样就可以平滑的切换PHP版本。如果之前版本的没有用,也可以回头第一步的时候将卸载。(有必要的时候再安装,没有必要就不要安装多个,毕竟占用资源。)

About 贝壳

【声明】:本博客不参与任何交易,也非中介,仅记录个人感兴趣的主机测评结果和优惠活动,内容均不作直接、间接、法定、约定的保证。访问本博客请务必遵守有关互联网的相关法律、规定与规则。一旦您访问本博客,即表示您已经知晓并接受了此声明通告。

 收藏 (0) 打赏

您可以选择一种方式赞助本站

支付宝扫一扫赞助

微信钱包扫描赞助

本文链接:贝壳主机网 » 宝塔面板安装不同PHP版本且可切换WordPress PHP版本升级

分享到: 生成海报
香港/美国/国内高速VPS
切换注册

登录

忘记密码 ?

切换登录

注册

我们将发送一封验证邮件至你的邮箱, 请正确填写以完成账号注册和激活